Plugin Flash en Ubuntu Hardy 64

 

Via: Arbol Charyou

Con todos los problemas que están dando Flash y Firefox, he tenido la necesidad de comprobar si el nuevo plugin de Flash introducía alguna mejora al respecto.

Lo primero que me encuentro al ejecutar el archivo de instalación es que no es compatible con mi arquitectura. Después de que en Hardy me llevara la grata sorpresa de no tener que usar nspluginwrapper para instalar Flash en la versión 64bits de Ubuntu, finalmente voy a tener que hacerlo.

• Desinstalamos el plugin existente:

$ sudo apt-get remove –purge flashplugin-nonfree

• Nos bajamos el archivo en formato tar.gz y lo descomprimimos. Necesitamos mover el archivo libflashplayer.so que contiene a /usr/lib/mozilla/plugins/.

$ tar zxf flashplayer10_install_linux_051508.tar.gz

$ cd install_flash_player_10_linux/

$ cp libflashplayer.so /usr/lib/mozilla/plugins/

• Ahora necesitamos los dos archivos de nspluginwrapper. Plugin y Viewer. Como están en formato .RPM los vamos a convertir en .DEB con alien.

$ alien -d archivo.rpm

• E instalamos los archivos resultantes.

$ sudo dpkg -i archivo.deb

• Una vez instalado nspluginwrapper, sólo queda preparar el plugin.

$ /usr/lib/nspluginwrapper/x86_64/linux/npconfig -i /usr/lib/mozilla/plugins/libflashplayer.so

• Reiniciamos Firefox y tecleamos about:plugins para comprobar que, efectivamente, se ha instalado Flash correctamente.

Deja un comentario